GreenR Community|The Community Run by You
Showing results for 
Search instead for 
Did you mean: 

Review: D-Link DWA-182 Wireless AC1200 USB Adapter

Windows™ Phone Expert



StarHub has recently given me the opportunity to test the another awesome D-Link product, the DWA-182 Wireless AC1200 Dual Band USB Adapter, which allows a computer to connect to a wireless network via USB.


It supports the latest Wireless AC standard which provides crazy fast wireless speeds of “up to 867mbps”.




The box contains the adapter, installation CD, USB extension and cradle.






I found the adapter to be considerably big, bigger than that of a Huawei E1762 for example. Its size makes it impossible for it to be plugged in next to another USB device should the ports be located too close to each other. This is, of course, where the USB extension comes in which doubles as a pleasant looking cradle.




The adapter does not work without setup which can be found on the CD or D-Link website. The installation is very straightforward and fast, and the adapter shows up as “WiFi” in network connections (note: you can rename this in Network Connections under Control Panel or “ncpa.cpl”). The drivers are installed with D-Link’s Wireless Connection Manager, which can manage wireless connections in place of Windows’ default connection management. It’s my opinion that it’s an extra hassle to use another software to manage wireless connections though, and thankfully, connection management can still be done through Windows. Furthermore, the D-Link Wireless Connection Manager failed to start on my Windows 8.1 laptop.


I tested my connection (300mbps, ASUS RT-AC66U Router):-

Connected through normal wireless: 53 mbps download (best of 3)

Connected through Ethernet: 323 mbps (best of 3)

Connected through the DWA-182: 210 mbps (best of 3)


I was astonished at the results, having such speeds for a wireless network is really amazing and unexpected. I’d definitely be using the wireless adapter instead of the inbuilt wireless from now until laptops start being built with 802.11ac support.


802.11ac technology is getting interesting with more and more devices starting to use them, including mobile phones such as the Nokia Lumia 1520 apparently shipping with 802.11ac. The 802.11ac wireless standard is still a draft though and may change (for the better), and the DWA-182 is an adapter that is built for 802.11ac draft standard. I’ll be looking forward to more devices with Wireless AC.

Windows Developer | @ReignOfComputer
Windows™ Phone Expert

It should be noted that the D-Link DWA-182 is NOT compatible with Mac OS X or other non-Windows platforms.



Edit: As it turns out I'm mistaken, see below comments.

Honored Advisor

Mac OS X and Linux drivers are available here.


Windows™ Phone Expert

Well, I'll be darned. Somehow those drivers eluded me when I was trying to get it working on my MacBook, hehehe. Guess I found an old forum post that stated they weren't available.


Thanks for bringing this to my attention Smiley Happy

Honored Advisor

It's been available since last month when I got the router/adpater set for testing. And it's working fine for me. Smiley Happy

New Commentator

I’ve been trying with my macbook pro, but I can’t get it right.

My mbp is a mid 2009, which doesn’t support usb 3, and my dongle is Ver HW: A1 FW: 1.01


The aiport on my mac is broken, so I have to use a cable... that’s where I thought this one would come in handy, but so far it hasn’t. In System Info (The ALT of "About my mac"), it shows as:

11ac Adapter:



  Leverandør-ID:0x2001  (D-Link Corporation)

  Versjon: 0.01


  HastighetSmiley Surprisedpptil 480 Mb/sek.


  Sted-ID:0x24100000 / 3

  Tilgjengelig strøm (mA):500

  Strømkrav (mA):Ukjent (enheten er ikke konfigurert) <--- not configured.


HOW did you get it to work, sginx? I’ve tried the drivers, without any luck. I tried with Mac OS X 10.8 and 10.9.


Kind regards,




by sglnx ‎24-09-2013 03:29 PM - edited ‎24-09-2013 03:30 PM

It's been available since last month when I got the router/adpater set for testing. And it's working fine for me. :smileyhappy: