GreenR Community|The Community Run by You
cancel
Showing results for 
Search instead for 
Did you mean: 

HappyRoam stopped working (due to software bug?)

Highlighted
Respected Commentator

HappyRoam stopped working (due to software bug?)

Activated Happy Roam 30 day 3.6GB plan before leaving SG on 3rd April. Everything setup and worked properly when I transitted at Taiwan. When leavng Taiwan still have 3.54GB left with $40 in balance. However everything stopped working after arrived at Vancouver airport 2 hours ago. Firstly data was charged with non-plan roaming rates. Balance shrank to $4.60 within 30 seconds. And till now I am not able to use my data romaing, tried multiple carriers including Rogers, Telus and Bell. There is simply no mobile data service even though I still have 3.54GB left. And very wieldly the plan expiration becomes 31/12/1969 16:00 HRS. Apparently this is a software bug when I crossed the timezone and walked back the time.

 

I would like to request StartHub to fix the issue and refund the extra charges asap. Thank you.

 

(Screenshots removed for privacy)

4 REPLIES 4
Highlighted
Respected Commentator

Re: HappyRoam stopped working (due to software bug?)

Not sure if someone worked on it. The expire date is set to 4th May this morning and data became available. But it worked for just 2 hours and went off again. This is very frustrating experience.

Highlighted
Community Manager

Re: HappyRoam stopped working (due to software bug?)

Hi karlzhou,

 

sorry for the frustration. Please try to restart your handset or placing your SIM Card in another handset to see if this helps resolve this issue? I've removed the screenshots you posted to protect your privacy as they contains your mobile number.

 

Please send the screenshots to me via private massage with your name and NRIC/FIN. Thank you!

Highlighted
Respected Commentator

Re: HappyRoam stopped working (due to software bug?)

Issue resolved after 3 overseas calls to Starhub customer service in 2 days, took me totally 1.5 hours net time on the phone! In the last phone call I had to wait till 1am to have the issue finally resolved, after I asked starhub customer service personel to deactivat and reactived my plan. Thanks to LDSG's post which led me to the solution.

 

I would also like to feedback that the technical expertise of customer supports varies a lot. The first person I called basically had no idea what I was talking about and could only say "yes I will esclate"; second person inisited that I need to top up my balace to over $3 and refused to listen to my reasoning; until the last person who was able to do the troubleshooting and helped me reset my account.

 

You may find my wording filled with complaint, but it did reflect the situation I faced: frustrations, lack of tangible helps from Starhub, and the anxiety of being disconned from work and family. I truely hope Starhub can improve it. Happy Roam is a great plan, but badly executed sometimes.

Highlighted
Respected Commentator

Re: HappyRoam stopped working (due to software bug?)

One more time I would like to thank LDSG and his post (https://community.starhub.com/t5/Prepaid/Prepaid-happy-roaming-in-USA/m-p/138887) which helped me.