GreenR Community|The Community Run by You
cancel
Showing results for 
Search instead for 
Did you mean: 

Port forwarding not working - Starhub using 2 routers?

SOLVED
Highlighted
Esteemed Commentator

Port forwarding not working - Starhub using 2 routers?

As some others have reported, I also cannot port forward on any port (eg, 8080, etc). 

 

However, Canyouseeme.com reports it sees my ports as open, but when I try to use any such port with a webhost, it cannot load.  I can load the page locally on mysubnet from another computer (192.168.0.x), so it is not a firewall problem on my computer host. 

 

Curiously, when using the "PF Router Detector" tool from portforward.com on my hosting machine, it reports there are 2 routers between my host and the outside world.  One is my router (192.168.0.1) and there is another outside of that (182.55.112.3) before getting to the outside world.  Huh? 

 

That would explain why some folks can port forward and others cannot.  Some like me might be under another router layer controlled by starhub which is not port forwarding. 

 

Do others see the same thing? 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Esteemed Commentator
Solution

Re: Port forwarding not working - Starhub using 2 routers?

Well, actually, it DOES work.  Surprisingly!  I took your thought and tried it from my mobile phone, and indeed I can load my website. 

 

What is curious, is that I cannot load it on my LAN using the WAN address.  When I am on a machine on my LAN at address 183.90.126.30, and I try to load 183.90.126.30, it fails.  But, from any other WAN address, it works.  Interesting. 

 

Well, I'm happy now. 

 

 

View solution in original post

9 REPLIES 9
Honored Advisor

Re: Port forwarding not working - Starhub using 2 routers?


@islander wrote:

As some others have reported, I also cannot port forward on any port (eg, 8080, etc). 

 

However, Canyouseeme.com reports it sees my ports as open, but when I try to use any such port with a webhost, it cannot load.  I can load the page locally on mysubnet from another computer (192.168.0.x), so it is not a firewall problem on my computer host. 

 

Curiously, when using the "PF Router Detector" tool from portforward.com on my hosting machine, it reports there are 2 routers between my host and the outside world.  One is my router (192.168.0.1) and there is another outside of that (182.55.112.3) before getting to the outside world.  Huh? 

 

That would explain why some folks can port forward and others cannot.  Some like me might be under another router layer controlled by starhub which is not port forwarding. 

 

Do others see the same thing? 

 

 


if you're using dlink's dir-865L router then you should use 'virtual server' instead of port forwarding. my settings are as such,

 

Screen shot 2014-04-12

 

then you should be able to access the webpage at http://182.55.112.3:8080

 

if you're using dlink's n5402p router, then look at ADVANCED → Firewall and DMZ → Virtual Server

do note that "Adding a client to the DMZ may expose that computer to a variety of security risks; so only use this option as a last resort." quoted from the router's user manual.

Esteemed Commentator

Re: Port forwarding not working - Starhub using 2 routers?

Doesn't work.

 

Actually, canyouseeme reports correctly my address as 183.90.126.30, and reports it can see me at 8080.  Trying 183.90.126.30:8080 fails, as does 182.55.112.3:8080. 

 

My DVG-N5304SP is configured using "Virtual Server" to open port 8080-8080 to a local 192.168.0.X machine running a webserver. 

 

On my local network I can load 192.168.0.x:8080 as a webpage. 

 

The PF Router Detector tool also correctly reports my public IP address as 183.90.126.30.  Interestingly, though it reports 2 routers between that public address and my local IP address 192.168.0.x.  One is correctly the DVG-5304SP at IP address 192.168.0.1, but there is another between my router and the outside, at IP address 182.55.112.3.  All my traffic must pass through that router as well.  I have no access or control over that 2nd router. 

 

I am strongly suspicious that 2nd router of starhub's is not configured to forward IP traffic. 

 

Honored Advisor

Re: Port forwarding not working - Starhub using 2 routers?


@islander wrote:

Doesn't work.

 

Actually, canyouseeme reports correctly my address as 183.90.126.30, and reports it can see me at 8080.  Trying 183.90.126.30:8080 fails, as does 182.55.112.3:8080. 

 

My DVG-N5304SP is configured using "Virtual Server" to open port 8080-8080 to a local 192.168.0.X machine running a webserver. 

 

On my local network I can load 192.168.0.x:8080 as a webpage. 

 

The PF Router Detector tool also correctly reports my public IP address as 183.90.126.30.  Interestingly, though it reports 2 routers between that public address and my local IP address 192.168.0.x.  One is correctly the DVG-5304SP at IP address 192.168.0.1, but there is another between my router and the outside, at IP address 182.55.112.3.  All my traffic must pass through that router as well.  I have no access or control over that 2nd router. 

 

I am strongly suspicious that 2nd router of starhub's is not configured to forward IP traffic. 

 


your so called 2nd router with ip addr 183.90.126.30 is actually an ip addr given to your router's WAN. the 192.168.0.0 is your local LAN and 192.168.0.1 is one of the computer in your LAN.

the 183.90.126.30 ip addr will keep changing depending on your ISP. to get around this problem, you may want to sign up an account at dlinkddns.com and use the dynamic dns service offered by dlink free of charge. so that when this ip addr changed, it will be updated at dlinkddns.com. in this way you can access your web server with a domain name like myserver.dlinkddns.com instead of those ip addr.

your virtual server setting on the router's configuration should look like:

 

Screen shot 2014-04-12 at PM 02.03.19.png


WAN Port Range: 8080-8080 (as you have chosen)

Assuming your 192.168.0.1 ip addr is static (ie. not changing), do note that this ip addr may change if the lease time is up. it depends on the period you set. Or you may reserved an ip addr for this computer that act as the web server.
Enter 192.168.0.1 into LAN Host IP Address
Server Port Range: (depends on what you set on your web server. normally the defaults is port 80)

Esteemed Commentator

Re: Port forwarding not working - Starhub using 2 routers?

Thanks for the help. 

 

I am doing everything you state.  I know the 183.90.126.30 is actually an ip addr given to my router's WAN.  I know, my router's LAN address is 192.168.0.1.  I also already use dynamic dds. 

 

My virtual server configuration looks exactly like you say.  Exactly.  I set my webserver to also port 8080 so the server port range is also 8080. 

 

The problem is that it is not working, you cannot load 183.90.126.30:8080 from the WAN. 

 

I can load the webpages on the local LAN using port 8080. 

 

In some way, starhub is blocking incoming traffic. 

 

 

Honored Advisor

Re: Port forwarding not working - Starhub using 2 routers?


@islander wrote:

Thanks for the help. 

 

I am doing everything you state.  I know the 183.90.126.30 is actually an ip addr given to my router's WAN.  I know, my router's LAN address is 192.168.0.1.  I also already use dynamic dds. 

 

My virtual server configuration looks exactly like you say.  Exactly.  I set my webserver to also port 8080 so the server port range is also 8080. 

 

The problem is that it is not working, you cannot load 183.90.126.30:8080 from the WAN. 

 

I can load the webpages on the local LAN using port 8080. 

 

In some way, starhub is blocking incoming traffic. 

 

 


could it be the firewall on the webserver is blocking access?

 

i'm using dlink 865L router and i'm able to access my test web site using my 3G phone. so i can conclude that starhub is not blocking traffic.

Esteemed Commentator

Re: Port forwarding not working - Starhub using 2 routers?

Nope.  Not the firewall. No difference when it is on or off, and futhermore, as stated, it works just fine on the local LAN.  I can reach it using hte 192.160.0.x address, and it displays fine using port 8080.  Works fine. 

 

It is just not accessible on my extern WAN IP address from anywhere. 

 

Starhub is blocking it. 

 

 

Esteemed Commentator
Solution

Re: Port forwarding not working - Starhub using 2 routers?

Well, actually, it DOES work.  Surprisingly!  I took your thought and tried it from my mobile phone, and indeed I can load my website. 

 

What is curious, is that I cannot load it on my LAN using the WAN address.  When I am on a machine on my LAN at address 183.90.126.30, and I try to load 183.90.126.30, it fails.  But, from any other WAN address, it works.  Interesting. 

 

Well, I'm happy now. 

 

 

View solution in original post

Honored Advisor

Re: Port forwarding not working - Starhub using 2 routers?


@islander wrote:

Well, actually, it DOES work.  Surprisingly!  I took your thought and tried it from my mobile phone, and indeed I can load my website. 

 

What is curious, is that I cannot load it on my LAN using the WAN address.  When I am on a machine on my LAN at address 183.90.126.30, and I try to load 183.90.126.30, it fails.  But, from any other WAN address, it works.  Interesting. 

 

Well, I'm happy now. 

 

 


i have no problem accessing my test web server using the "WAN ip addr:port number" on my LAN.

Honored Contributor

Re: Port forwarding not working - Starhub using 2 routers?

Hi islander,

 

If you are able to access WANSmiley TongueORT through your Mobile but is unable to access the same on LAN; my guess would be NAT Loopback is not supported/enabled on your router.

 

Take a look at this: Network address translation - Wikipedia, the free encyclopedia