StarHub Community|The Community Run by You
cancel
Showing results for 
Search instead for 
Did you mean: 

Slow speed on new Linksys EA7500

Community Manager

Re: Slow speed on new Linksys EA7500

I see. Let me know if the replacement doesn't work. I'll be happy to arrange for technical assistance. 

 

- Amy
Honored Contributor

Re: Slow speed on new Linksys EA7500

 I am looking at my Linksys Smart Wifi admin site (192.168.1.1) and the Network Status panel is switch between connected and not connected frquently. Is that proper?

 

NoInternet.JPG

Internet.JPG

Alumni (Retired)

Re: Slow speed on new Linksys EA7500

Hi Kenny_, have you tried to restart your router to see if that stabilizes it?

 

If that didn't help, please PM me your NRIC/FIN, StarHub account number, email and mobile so that I can verify your account and then immediately escalate this to the technical team. Thanks. - Sal

- Sal
Honored Contributor

Re: Slow speed on new Linksys EA7500

Hi Salehuddin_H,

 

   Yes, I have restarted both the router and also the ONT last night. Will my prevoius router (Dlink Dir-868L) just work if I swap it with the new router?

Community Manager

Re: Slow speed on new Linksys EA7500

Yes, your old router settings should still be on your old router. You can do the swap now while waiting for the replacement to reach you.

 

- Amy
Honored Contributor

Re: Slow speed on new Linksys EA7500

Last night, the EA7500's experience improved to the extent that I did not notice any difference with the Dlink-DIR868L. There is no more stutter when surfing and YouTube never show buffering animations at all. Will continue to monitor. Seems like its stabilizing.
Community Manager

Re: Slow speed on new Linksys EA7500

That's good to hear. Let me know if you've other queries. 

 

- Amy
Senior Commentator

Re: Slow speed on new Linksys EA7500

I am not sure if anyone is still having the problem. I chanced upon this thread when I ran into the same problem with my Linksys EA7500 which I received after recontracting recently. 

 

I updated my firmware immediately upon receiving the modem. At first, things went well.  S8+ clocked 500Mbps on speed test. But the speed dropped to just 300+ after a while. So I wiped the modem to factory default and started all over again. Same thing happened. Was ok for a while, then speed dropped. Then I performed a restart by turning the modem off and plugging out the power cable. Again, it is fine now, but I am not sure when the speed will drop again.

 

Is there a way for the user to perform a self-check to verify if the modem is faulty? This is very disappointing. It is supposed to be an upgrade from the D link but it is turning out worse. 

Senior Contributor

Re: Slow speed on new Linksys EA7500

Same here. Speed drop and lost connection to internet. Tried several possible fixes, all didin't work.
Community Manager

Re: Slow speed on new Linksys EA7500

Hi Shaiful, how's the connection now? Any better?