Skip to main content

Valued Commentator

 • 

2 Messages

Thu, Jul 20, 2017 6:00 AM

Starhub Go - my app not compatible with my phone?

Responses

Valued Commentator

 • 

2 Messages

3 years ago

Hi,

 

I would like to ask why is the starhub go not compatible with my phone?

ASUS ZenFone (ASUS_Z011D)

Andriod 6.0.1

 

Thanks

 

eric3743

Grand Guru

 • 

4.4K Messages

3 years ago

First have you try to see if there is any updates to your phone.

It depend on the Android version and phone chipset/CPU compatiblity to run any Apps.

 

With regarding to Google apps & any other apps, they have always do updates on the app itself.

Some to the apps may be improvement, and also security issues.

 

As your issue, there is another method to try.

 

This link will bring you to the Starhub Go APK.

>> Starhub Go APK Download

 

You can download the apk in the link and install to your phone.

Should a version run without any issues, then continue to use it but do not update.

 

Most developer do provide past versions of the program, apps, software, etc.

Since if the current version cannot work, there is a possibility that an older version will work.

 

 

i am not starhub staff &or related to.

New Commentator

 • 

1 Message

3 years ago

[removed for infringement content]

Get Started

Get Started