U

9 Messages

 • 

9 Points

Mon, Apr 19, 2021 2:57 AM

How to activate Dolby Digital on the Starhub TV+ Box

My setup: Starhub TV+, Philipps TV, Sonos Playbar, Sonos Sub, Sonos Play 1 (for surround)

My Sonos app says the audio is "Stereo PCM". I set up my TV audio for Surround Sound + Audio = multichannel, and my Starhub TV+ setting (online) says "Digital Dolby".

When I run audio / video from my Apple TV, I get "Digital Dolby" and great sound.

I also called customer service. At first the agent said "Dolby Digital" is not available on TV+. After numerous checks, the agent said it is available and it should be automatic. But I still only see "Stereo PCM".

Anyone have any ideas?

Responses

141 Messages

 • 

139 Points

2 m ago

Try manually enabling it in the sound settings of the box.

It's under device preferences

(edited)

9 Messages

 • 

9 Points

In the end, I run Netflix, Disney+, Amazon Prime through my Apple TV and I am able to get Digital Dolby 5.1.

And then use Starhub TV+ to watch TV.

Carla_P

Moderator

 • 

4.6K Messages

 • 

2.4K Points

2 m ago

Hi @user_cc428c, also, please ensure your StarHub TV+ Box is updated. Go to Android TV Settings > Device Preferences > About > System update > Check for update. You will be notified to install the new software update when it is made available. 

~ Carla

 

 

▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬
Some of my posts, opinions and views here do not reflect my position and StarHub's opinions. 
For account related matter, please seek help from our Customer Service team via Facebook Messenger.
Have a good idea? Tell us at our Ideas Exchange!

9 Messages

 • 

9 Points

@Carla_P It says "System is up to date"

Get Started

Get Started