W

3 Messages

 • 

3 Points

Sat, Mar 13, 2021 9:16 AM

Starhub new TV+ box unable to watch local channels (TV5, 8, Channel U, channel News Asia)

Hi,

I see that many people here facing the same issues as me.  

I have gotten the new Starhub TV+ box today.  I am using Linksys EA7500 router and to the TV+ box.  I can watch the subscribed channels, Disney+ and Netflix through the TV+ box. But unable to watch the local Mediacorp channels. 

When I press "107" for Channel U, it says "Please subscribe to the relevant package to view this channel."  
Do I need to subscribe to free-to-air channels?

Called 1633 hotline to troubleshoot (on/off all the different devices multiple times), but it is still not working.   The staff advise me to bring the box to Starhub shops for a 1-to-1 exchange, it is a new box and it is faulty?    For your information, I have 2 TV boxes (one more box for my parents' room), and both are not working, does it means both NEW boxes are faulty?   I don't believe that Starhub TV+ boxes have such high faulty rates, right?  

Responses

7 Messages

 • 

7 Points

3 m ago

What model of router are you using currently? 

3 Messages

 • 

3 Points

@zacharyquek Linksys EA7500

Carla_P

Moderator

 • 

4.6K Messages

 • 

2.4K Points

3 m ago

Hi @waituck47, sorry for the inconvenience this has caused you. Please be informed that to enjoy free-to-air channels, you will need your StarHub TV+ Box to be connected to a StarHub Smart WiFi router or a Linksys router model, EA7500v2 or EA8100 with a StarHub Broadband connection. 

~ Carla

 

 

▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬
Some of my posts, opinions and views here do not reflect my position and StarHub's opinions. 
For account related matter, please seek help from our Customer Service team via Facebook Messenger.
Have a good idea? Tell us at our Ideas Exchange!
JT1

Esteemed Commentator

 • 

18 Messages

 • 

12 Points

I was able to solve a similar issue by resetting my EA8100 router (factory reset) - took around 30mins   

3 Messages

 • 

3 Points

@Carla_P Before I signed up with the new Starhub TV+ box, I have double confirm with the Starhub staff that my Router is OK.

Mine is Linksys EA7500.

Carla_P

Moderator

 • 

4.6K Messages

 • 

2.4K Points

Please try to do a factory reset to your Linksys router to see if the issue persists.

~ Carla

 

 

▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬
Some of my posts, opinions and views here do not reflect my position and StarHub's opinions. 
For account related matter, please seek help from our Customer Service team via Facebook Messenger.
Have a good idea? Tell us at our Ideas Exchange!

3 Messages

 • 

3 Points

3 m ago

hi there,

may i get some help here?
i am an existing starhub broadband client using Linksys router EA8100 and i just had my starhub TV+ box installed a few weeks ago.  I was able to watch netflix, youtube etc.  Only had problem connecting to our local mediacorp TV channels.

I went through Starhub FAQ to try trouble shoot the problem.  I checked the STB connection - everything is ok except step 4 where it says the service status for the STB Mode should be "On-net". But mine is reflected at "Off-net".  there seems no option for me to manually change this.  what should i do?

thanks for the help in advanced.

Carla_P

Moderator

 • 

4.6K Messages

 • 

2.4K Points

Hi @wong horng hien, sorry for the inconvenience this has caused. Please ensure your router is on its latest firmware version. Also, you may refer to @JT1's comment on this thread on how he was able to fix the issue. 

~ Carla

 

 

▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬
Some of my posts, opinions and views here do not reflect my position and StarHub's opinions. 
For account related matter, please seek help from our Customer Service team via Facebook Messenger.
Have a good idea? Tell us at our Ideas Exchange!

3 Messages

 • 

3 Points

hi carla, thanks for your reply.  i belong to older generation and one of those who is IT-naive.  How do i ensure my router is on its latest firmware version... this term is too technical for me.  i referred @JT1's comment.. he reset the router to factory setting... hmm, is there a button on the router to do that?.... getting this up and running is such challenge.

Carla_P

Moderator

 • 

4.6K Messages

 • 

2.4K Points

Let me also clarify, if your set-top box is on a wired connection to your Linksys router? 

 

To check if your router is running on its latest firmware 1.0.2.203018, please download the Linksys App from the App Store or Google Play Store. Thereafter, simply follow the steps below. 

Image

 

  1. To check the current firmware version, select the menu icon.
  2. Under menu, select Network Administration
  3. Under Network Administration, ensure that Automatic Firmware Update is enabled.
  4. Select your Linksys Router and ensure that the Firmware Version is updated.

To reset your Linksys router, press and hold the Reset button on the back panel of the Linksys EA8100 for about 10 seconds.

 

~ Carla

 

 

▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬
Some of my posts, opinions and views here do not reflect my position and StarHub's opinions. 
For account related matter, please seek help from our Customer Service team via Facebook Messenger.
Have a good idea? Tell us at our Ideas Exchange!

1 Message

 • 

1 Point

2 m ago

Hi I am using linksys EA7500 too with the latest firmware and wired connection to starhub tv+ but still no local free to air channel please assist thanks

141 Messages

 • 

139 Points

Can you try factory resetting the router?

(edited)

Carla_P

Moderator

 • 

4.6K Messages

 • 

2.4K Points

Hi @user_a0d409, I'm sorry to hear that you're unable to access free-to-air channels. Please ensure that for Linksys router EA7500 that the firmware should be 1.0.2.203018. Also, check if your set-top box is on net or off net. Just go to my account (top right of the screen) > My Account > STB information.  If status is offnet, please ensure that the connection is ONT > Compatible Router > StarHub TV+ Box as illustrated below:

(edited)

~ Carla

 

 

▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬
Some of my posts, opinions and views here do not reflect my position and StarHub's opinions. 
For account related matter, please seek help from our Customer Service team via Facebook Messenger.
Have a good idea? Tell us at our Ideas Exchange!

141 Messages

 • 

139 Points

@Carla_P Sorry but the person clearly said they are using the EA7500 router not the other one. Also in the picture, it says "Linskys" not "Linksys"

Carla_P

Moderator

 • 

4.6K Messages

 • 

2.4K Points

Ooops. Sorry, it's the wrong image. Thanks for the correction. 

~ Carla

 

 

▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬
Some of my posts, opinions and views here do not reflect my position and StarHub's opinions. 
For account related matter, please seek help from our Customer Service team via Facebook Messenger.
Have a good idea? Tell us at our Ideas Exchange!

Get Started

Get Started